Debian
debian
10,156 CVEs • 112 products
Products (112)
Click to collapseToggle
Products (112)
Click to collapse
CVEs (10,156)
CVE VENDORS PRODUCTS UPDATED PUBLISHED CVSS |
|---|
3Debian HaxxSplunk3Curl Debian LinuxUniversal ForwarderOct 14, 2026 Jun 2, 2022 N/A· v4 7.5 HIGH· v3 5.0 MEDIUM· v2 libcurl would reuse a previously created connection even when a TLS or SSHrelated option had been changed that should have prohibited reuse.libcurl keeps previously used connections in a connection pool for subsequenttra...Show more |
4Debian HaxxNetapp+1 more12Clustered Data Ontap CurlDebian Linux+9 moreOct 14, 2026 Jun 2, 2022 N/A· v4 7.5 HIGH· v3 5.0 MEDIUM· v2 libcurl provides the `CURLOPT_CERTINFO` option to allow applications torequest details to be returned about a server's certificate chain.Due to an erroneous function, a malicious server could make libcurl built withNSS g...Show more |
6Broadcom DebianFedoraproject+3 more13Clustered Data Ontap CurlDebian Linux+10 moreOct 14, 2026 Jun 2, 2022 N/A· v4 6.5 MEDIUM· v3 4.3 MEDIUM· v2 A insufficiently protected credentials vulnerability in fixed in curl 7.83.0 might leak authentication or cookie header data on HTTP redirects to the same host but another port number. |
5Broadcom DebianHaxx+2 more12Clustered Data Ontap CurlDebian Linux+9 moreOct 14, 2026 Jun 2, 2022 N/A· v4 7.5 HIGH· v3 5.0 MEDIUM· v2 An information disclosure vulnerability exists in curl 7.65.0 to 7.82.0 are vulnerable that by using an IPv6 address that was in the connection pool but with a different zone id it could reuse a connection instead. |
5Broadcom DebianHaxx+2 more12Clustered Data Ontap CurlDebian Linux+9 moreOct 14, 2026 Jun 2, 2022 N/A· v4 5.7 MEDIUM· v3 3.5 LOW· v2 An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authenticat...Show more |
2Debian Pidgin2Debian Linux PidginJun 17, 2026 Jun 2, 2022 N/A· v4 5.9 MEDIUM· v3 4.3 MEDIUM· v2 An issue was discovered in Pidgin before 2.14.9. A remote attacker who can spoof DNS responses can redirect a client connection to a malicious server. The client will perform TLS certificate verification of the malicious...Show more |
3Apple DebianVim3Debian Linux MacosVimJun 17, 2026 Jun 2, 2022 N/A· v4 7.8 HIGH· v3 6.8 MEDIUM· v2 Use After Free in GitHub repository vim/vim prior to 8.2. |
4Debian FedoraprojectLinux+1 more4Debian Linux Enterprise LinuxFedora+1 moreJun 17, 2026 Jun 2, 2022 N/A· v4 6.8 MEDIUM· v3 6.9 MEDIUM· v2 With shadow paging enabled, the INVPCID instruction results in a call to kvm_mmu_invpcid_gva. If INVPCID is executed with CR0.PG=0, the invlpg callback is not set and the result is a NULL pointer dereference. |
4Debian LinuxNetapp+1 more8Debian Linux Enterprise LinuxH300s Firmware+5 moreJun 17, 2026 Jun 2, 2022 N/A· v4 7.8 HIGH· v3 7.2 HIGH· v2 Linux Kernel could allow a local attacker to execute arbitrary code on the system, caused by a concurrency use-after-free flaw in the bad_flp_intr function. By executing a specially-crafted program, an attacker could exp...Show more |
3Debian LinuxRedhat3Debian Linux Enterprise LinuxLinux KernelOct 14, 2026 Jun 2, 2022 N/A· v4 6.3 MEDIUM· v3 3.3 LOW· v2 An out-of-bounds read flaw was found in the Linux kernel’s TeleTYpe subsystem. The issue occurs in how a user triggers a race condition using ioctls TIOCSPTLCK and TIOCGPTPEER and TIOCSTI and TCXONC with leakage of memor...Show more |
2Debian Linux2Debian Linux Linux KernelJun 17, 2026 Jun 2, 2022 N/A· v4 7.8 HIGH· v3 4.6 MEDIUM· v2 The root cause of this vulnerability is that the ioctl$DRM_IOCTL_MODE_DESTROY_DUMB can decrease refcount of *drm_vgem_gem_object *(created in *vgem_gem_dumb_create*) concurrently, and *vgem_gem_dumb_create *will access t...Show more |
2Debian Signalwire2Debian Linux Sofia SipJun 17, 2026 May 31, 2022 N/A· v4 9.8 CRITICAL· v3 7.5 HIGH· v2 Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, when parsing each line of a sdp message, `rest = record + 2` will access the memory behind `\0` and cause an out-...Show more |
2Debian Signalwire2Debian Linux Sofia SipJun 17, 2026 May 31, 2022 N/A· v4 7.5 HIGH· v3 5.0 MEDIUM· v2 Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause crash. This type of crash may be caus...Show more |
2Debian Signalwire2Debian Linux Sofia SipJun 17, 2026 May 31, 2022 N/A· v4 7.5 HIGH· v3 5.0 MEDIUM· v2 Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause a crash. This type of crash may be ca...Show more |
4Apple DebianFedoraproject+1 more4Debian Linux FedoraMacos+1 moreJun 17, 2026 May 31, 2022 N/A· v4 7.8 HIGH· v3 6.8 MEDIUM· v2 Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2. |
4Apple DebianFedoraproject+1 more4Debian Linux FedoraMacos+1 moreJun 17, 2026 May 27, 2022 N/A· v4 7.8 HIGH· v3 6.8 MEDIUM· v2 Out-of-bounds Write in GitHub repository vim/vim prior to 8.2. |
4Apple DebianFedoraproject+1 more4Debian Linux FedoraMacos+1 moreJun 17, 2026 May 27, 2022 N/A· v4 7.8 HIGH· v3 6.8 MEDIUM· v2 Use After Free in GitHub repository vim/vim prior to 8.2. |
4Apple DebianFedoraproject+1 more6Cups CupsDebian Linux+3 moreJun 17, 2026 May 26, 2022 N/A· v4 6.7 MEDIUM· v3 7.2 HIGH· v2 A logic issue was addressed with improved state management. This issue is fixed in Security Update 2022-003 Catalina, macOS Monterey 12.3, macOS Big Sur 11.6.5. An application may be able to gain elevated privileges. |
2Debian Rubyonrails2Actionpack Debian LinuxJun 17, 2026 May 26, 2022 N/A· v4 6.1 MEDIUM· v3 4.3 MEDIUM· v2 A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes. |
2Debian Rubyonrails2Actionpack Debian LinuxJun 17, 2026 May 26, 2022 N/A· v4 6.1 MEDIUM· v3 4.3 MEDIUM· v2 An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses. |