← Back

Enterprise Linux

enterprise_linux

Vendor: Redhat • 1,952 CVEs

CVEs (1,952)

CVE
VENDORS
PRODUCTS
UPDATED
PUBLISHED
CVSS
2Fedoraproject
Redhat
19Codeready Linux Builder
Codeready Linux Builder EusCodeready Linux Builder Eus For Power Little Endian+16 more
Aug 6, 2026
Feb 15, 2024
N/A· v4
7.3 HIGH· v3
N/A· v2
A vulnerability was found in Unbound due to incorrect default permissions, allowing any process outside the unbound group to modify the unbound runtime configuration. If a process can connect over localhost to port 8953,...Show more
A vulnerability was found in Unbound due to incorrect default permissions, allowing any process outside the unbound group to modify the unbound runtime configuration. If a process can connect over localhost to port 8953, it can alter the configuration of unbound.service. This flaw allows an unprivileged attacker to manipulate a running instance, potentially altering forwarders, allowing them to track all queries forwarded by the local resolver, and, in some cases, disrupting resolving altogether.Show less
6Debian
FedoraprojectIsc+3 more
8Active Iq Unified Manager
BindBootstrap Os+5 more
Jun 17, 2026
Feb 14, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in...Show more
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.Show less
8Fedoraproject
IscMicrosoft+5 more
13Bind
DnsmasqEnterprise Linux+10 more
Jun 17, 2026
Feb 14, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue...Show more
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.Show less
3Fedoraproject
Opensc ProjectRedhat
3Enterprise Linux
FedoraOpensc
Jun 17, 2026
Feb 12, 2024
N/A· v4
3.4 LOW· v3
N/A· v2
The use-after-free vulnerability was found in the AuthentIC driver in OpenSC packages, occuring in the card enrolment process using pkcs15-init when a user or administrator enrols or modifies cards. An attacker must have...Show more
The use-after-free vulnerability was found in the AuthentIC driver in OpenSC packages, occuring in the card enrolment process using pkcs15-init when a user or administrator enrols or modifies cards. An attacker must have physical access to the computer system and requires a crafted USB device or smart card to present the system with specially crafted responses to the APDUs, which are considered high complexity and low severity. This manipulation can allow for compromised card management operations during enrolment.Show less
3Fedoraproject
LatchsetRedhat
6Enterprise Linux
Enterprise Linux For Arm 64Enterprise Linux For Ibm Z Systems+3 more
Jun 17, 2026
Feb 12, 2024
N/A· v4
5.3 MEDIUM· v3
N/A· v2
A vulnerability was found in JWCrypto. This flaw allows an attacker to cause a denial of service (DoS) attack and possible password brute-force and dictionary attacks to be more resource-intensive. This issue can result...Show more
A vulnerability was found in JWCrypto. This flaw allows an attacker to cause a denial of service (DoS) attack and possible password brute-force and dictionary attacks to be more resource-intensive. This issue can result in a large amount of computational consumption, causing a denial of service attack.Show less
2Fedoraproject
Redhat
13389 Directory Server
Directory ServerEnterprise Linux+10 more
Jun 17, 2026
Feb 12, 2024
N/A· v4
5.5 MEDIUM· v3
N/A· v2
A heap overflow flaw was found in 389-ds-base. This issue leads to a denial of service when writing a value larger than 256 chars in log_entry_attr.
4Debian
FedoraprojectLinux+1 more
4Debian Linux
Enterprise LinuxFedora+1 more
Jun 17, 2026
Feb 11, 2024
N/A· v4
5.5 MEDIUM· v3
N/A· v2
A vulnerability was reported in the Open vSwitch sub-component in the Linux Kernel. The flaw occurs when a recursive operation of code push recursively calls into the code block. The OVS module does not validate the stac...Show more
A vulnerability was reported in the Open vSwitch sub-component in the Linux Kernel. The flaw occurs when a recursive operation of code push recursively calls into the code block. The OVS module does not validate the stack depth, pushing too many frames and causing a stack overflow. As a result, this can lead to a crash or other related issues.Show less
3Fedoraproject
RedhatX.org
8Enterprise Linux
Enterprise Linux AusEnterprise Linux Eus+5 more
Jun 17, 2026
Feb 9, 2024
N/A· v4
7.8 HIGH· v3
N/A· v2
An out-of-bounds memory access flaw was found in the X.Org server. This issue can be triggered when a device frozen by a sync grab is reattached to a different master device. This issue may lead to an application crash,...Show more
An out-of-bounds memory access flaw was found in the X.Org server. This issue can be triggered when a device frozen by a sync grab is reattached to a different master device. This issue may lead to an application crash, local privilege escalation (if the server runs with extended privileges), or remote code execution in SSH X11 forwarding environments.Show less
3Debian
LinuxRedhat
17Codeready Linux Builder Eus
Codeready Linux Builder Eus For Power Little Endian EusCodeready Linux Builder For Arm64 Eus+14 more
Jun 17, 2026
Feb 7, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer derefe...Show more
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer dereference in the NVMe driver, causing kernel panic and a denial of service.Show less
2Linux
Redhat
16Codeready Linux Builder Eus
Codeready Linux Builder Eus For Power Little Endian EusCodeready Linux Builder For Arm64 Eus+13 more
Jun 17, 2026
Feb 7, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer derefe...Show more
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer dereference in the NVMe driver, causing kernel panic and a denial of service.Show less
3Debian
LinuxRedhat
17Codeready Linux Builder Eus
Codeready Linux Builder Eus For Power Little Endian EusCodeready Linux Builder For Arm64 Eus+14 more
Jun 17, 2026
Feb 7, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer derefe...Show more
A flaw was found in the Linux kernel's NVMe driver. This issue may allow an unauthenticated malicious actor to send a set of crafted TCP packages when using NVMe over TCP, leading the NVMe driver to a NULL pointer dereference in the NVMe driver and causing kernel panic and a denial of service.Show less
3Fedoraproject
GnuRedhat
3Enterprise Linux
FedoraGrub2
Jun 17, 2026
Feb 6, 2024
N/A· v4
3.3 LOW· v3
N/A· v2
A flaw was found in the grub2-set-bootflag utility of grub2. After the fix of CVE-2019-14865, grub2-set-bootflag will create a temporary file with the new grubenv content and rename it to the original grubenv file. If th...Show more
A flaw was found in the grub2-set-bootflag utility of grub2. After the fix of CVE-2019-14865, grub2-set-bootflag will create a temporary file with the new grubenv content and rename it to the original grubenv file. If the program is killed before the rename operation, the temporary file will not be removed and may fill the filesystem when invoked multiple times, resulting in a filesystem out of free inodes or blocks.Show less
2Fedoraproject
Redhat
6Ansible
Ansible Automation PlatformAnsible Developer+3 more
Jun 17, 2026
Feb 6, 2024
N/A· v4
5.5 MEDIUM· v3
N/A· v2
An information disclosure flaw was found in ansible-core due to a failure to respect the ANSIBLE_NO_LOG configuration in some scenarios. Information is still included in the output in certain tasks, such as loop items. D...Show more
An information disclosure flaw was found in ansible-core due to a failure to respect the ANSIBLE_NO_LOG configuration in some scenarios. Information is still included in the output in certain tasks, such as loop items. Depending on the task, this issue may include sensitive information, such as decrypted secret values.Show less
3Couchbase
Cryptography.ioRedhat
5Ansible Automation Platform
Couchbase ServerCryptography+2 more
Jun 17, 2026
Feb 5, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
A flaw was found in the python-cryptography package. This issue may allow a remote attacker to decrypt captured messages in TLS servers that use RSA key exchanges, which may lead to exposure of confidential or sensitive...Show more
A flaw was found in the python-cryptography package. This issue may allow a remote attacker to decrypt captured messages in TLS servers that use RSA key exchanges, which may lead to exposure of confidential or sensitive data.Show less
2M2crypto Project
Redhat
3Enterprise Linux
M2cryptoUpdate Infrastructure
Oct 15, 2026
Feb 5, 2024
N/A· v4
7.5 HIGH· v3
N/A· v2
A flaw was found in m2crypto. This issue may allow a remote attacker to decrypt captured messages in TLS servers that use RSA key exchanges, which may lead to exposure of confidential or sensitive data.
2Gnu
Redhat
2Cpio
Enterprise Linux
Jun 17, 2026
Feb 5, 2024
N/A· v4
5.3 MEDIUM· v3
N/A· v2
A path traversal vulnerability was found in the CPIO utility. This issue could allow a remote unauthenticated attacker to trick a user into opening a specially crafted archive. During the extraction process, the archiver...Show more
A path traversal vulnerability was found in the CPIO utility. This issue could allow a remote unauthenticated attacker to trick a user into opening a specially crafted archive. During the extraction process, the archiver could follow symlinks outside of the intended directory, which allows files to be written in arbitrary directories through symlinks.Show less
2Linux
Redhat
2Enterprise Linux
Linux Kernel
Jun 17, 2026
Feb 4, 2024
N/A· v4
6.5 MEDIUM· v3
N/A· v2
A Marvin vulnerability side-channel leakage was found in the RSA decryption operation in the Linux Kernel. This issue may allow a network attacker to decrypt ciphertexts or forge signatures, limiting the services that us...Show more
A Marvin vulnerability side-channel leakage was found in the RSA decryption operation in the Linux Kernel. This issue may allow a network attacker to decrypt ciphertexts or forge signatures, limiting the services that use that private key.Show less
2Opensc Project
Redhat
11Enterprise Linux
Enterprise Linux EusEnterprise Linux For Arm 64+8 more
Jun 17, 2026
Jan 31, 2024
N/A· v4
5.9 MEDIUM· v3
N/A· v2
A vulnerability was found in OpenSC where PKCS#1 encryption padding removal is not implemented as side-channel resistant. This issue may result in the potential leak of private data.
2Opencryptoki Project
Redhat
2Enterprise Linux
Opencryptoki
Jun 17, 2026
Jan 31, 2024
N/A· v4
5.9 MEDIUM· v3
N/A· v2
A timing side-channel vulnerability has been discovered in the opencryptoki package while processing RSA PKCS#1 v1.5 padded ciphertexts. This flaw could potentially enable unauthorized RSA ciphertext decryption or signin...Show more
A timing side-channel vulnerability has been discovered in the opencryptoki package while processing RSA PKCS#1 v1.5 padded ciphertexts. This flaw could potentially enable unauthorized RSA ciphertext decryption or signing, even without access to the corresponding private key.Show less
2Linux
Redhat
2Enterprise Linux
Linux Kernel
Jun 17, 2026
Jan 30, 2024
N/A· v4
6.5 MEDIUM· v3
N/A· v2
A flaw was found in the Linux kernel's memory deduplication mechanism. The max page sharing of Kernel Samepage Merging (KSM), added in Linux kernel version 4.4.0-96.119, can create a side channel. When the attacker and t...Show more
A flaw was found in the Linux kernel's memory deduplication mechanism. The max page sharing of Kernel Samepage Merging (KSM), added in Linux kernel version 4.4.0-96.119, can create a side channel. When the attacker and the victim share the same host and the default setting of KSM is "max page sharing=256", it is possible for the attacker to time the unmap to merge with the victim's page. The unmapping time depends on whether it merges with the victim's page and additional physical pages are created beyond the KSM's "max page share". Through these operations, the attacker can leak the victim's page.Show less