← Back
CWE-79

49,121 CVEs • Abstraction: Base • Likelihood of Exploit: High

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

JSON object

Loading...

CVEs (49,121)

CVE
VENDORS
PRODUCTS
UPDATED
PUBLISHED
CVSS
1Dolibarr
1Dolibarr
Nov 21, 2024
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers to inject arbitrary web script or HTML via the foruserlogin parameter to adherents/cartes/carte.php.
1Hp
2Network Automation
Network Operations Management Ultimate
Jun 17, 2026
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Persistent Cross-Site Scripting, and non-persistent HTML Injection in HP Network Operations Management Ultimate, version 2017.07, 2017.11, 2018.02 and in Network Automation, version 10.00, 10.10, 10.11, 10.20, 10.30, 10....Show more
Persistent Cross-Site Scripting, and non-persistent HTML Injection in HP Network Operations Management Ultimate, version 2017.07, 2017.11, 2018.02 and in Network Automation, version 10.00, 10.10, 10.11, 10.20, 10.30, 10.40, 10.50. This vulnerability could be remotely exploited to allow persistent cross-site scripting, and non-persistent HTML Injection.Show less
1Ckeditor
1Ckeditor 5 Link
Nov 21, 2024
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Cross-site scripting (XSS) vulnerability in the Link package for CKEditor 5 before 10.0.1 allows remote attackers to inject arbitrary web script through a crafted href attribute of a link (A) element.
1Joomla
1Joomla
Jun 17, 2026
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
In Joomla! Core before 3.8.8, inadequate filtering of file and folder names leads to various XSS attack vectors in the media manager.
1Joomla
1Joomla
Nov 21, 2024
May 22, 2018
N/A· v4
4.7 MEDIUM· v3
2.6 LOW· v2
An issue was discovered in Joomla! Core before 3.8.8. Under specific circumstances (a redirect issued with a URI containing a username and password when the Location: header cannot be used), a lack of escaping the user-i...Show more
An issue was discovered in Joomla! Core before 3.8.8. Under specific circumstances (a redirect issued with a URI containing a username and password when the Location: header cannot be used), a lack of escaping the user-info component of the URI could result in an XSS vulnerability.Show less
1Joomla
1Joomla
Nov 21, 2024
May 22, 2018
N/A· v4
4.8 MEDIUM· v3
3.5 LOW· v2
An issue was discovered in Joomla! Core before 3.8.8. Inadequate input filtering leads to a multiple XSS vulnerabilities. Additionally, the default filtering settings could potentially allow users of the default Administ...Show more
An issue was discovered in Joomla! Core before 3.8.8. Inadequate input filtering leads to a multiple XSS vulnerabilities. Additionally, the default filtering settings could potentially allow users of the default Administrator user group to perform a XSS attack.Show less
1Loginizer
1Loginizer
Nov 21, 2024
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
init.php in the Loginizer plugin 1.3.8 through 1.3.9 for WordPress has Unauthenticated Stored Cross-Site Scripting (XSS) because logging is mishandled. This is fixed in 1.4.0.
1Asustor
1Soundsgood
Nov 21, 2024
May 22, 2018
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
A persistent cross site scripting vulnerability in playlistmanger.cgi in the ASUSTOR SoundsGood application allows attackers to store cross site scripting payloads via the 'playlist' POST parameter.
1Frappe
1Erpnext
Nov 21, 2024
May 22, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An XSS issue was discovered in Frappe ERPNext v11.x.x-develop b1036e5 via a comment.
1Jenkins
1Jenkins
Nov 21, 2024
May 21, 2018
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting vulnerability in console notes (SECURITY-382). Jenkins allows plugins to annotate build logs, adding new content or changing the pres...Show more
jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting vulnerability in console notes (SECURITY-382). Jenkins allows plugins to annotate build logs, adding new content or changing the presentation of existing content while the build is running. Malicious Jenkins users, or users with SCM access, could configure jobs or modify build scripts such that they print serialized console notes that perform cross-site scripting attacks on Jenkins users viewing the build logs.Show less
1Pluck Cms
1Pluck
Nov 21, 2024
May 21, 2018
N/A· v4
4.8 MEDIUM· v3
3.5 LOW· v2
An issue was discovered in Pluck before 4.7.6. There is authenticated stored XSS because the character set for filenames is not properly restricted.
1Adobe
1Coldfusion
Nov 21, 2024
May 19, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Adobe ColdFusion Update 5 and earlier versions, ColdFusion 11 Update 13 and earlier versions have an exploitable Cross-Site Scripting vulnerability. Successful exploitation could lead to information disclosure.
1Adobe
1Coldfusion
Nov 21, 2024
May 19, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Adobe ColdFusion Update 5 and earlier versions, ColdFusion 11 Update 13 and earlier versions have an exploitable Cross-Site Scripting vulnerability. Successful exploitation could lead to information disclosure.
1Adobe
1Experience Manager
Nov 21, 2024
May 19, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Adobe Experience Manager versions 6.1 and earlier have an exploitable stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure.
1Adobe
1Experience Manager
Nov 21, 2024
May 19, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Adobe Experience Manager versions 6.3 and earlier have an exploitable Cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure.
1Adobe
1Experience Manager
Nov 21, 2024
May 19, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Adobe Experience Manager versions 6.2 and earlier have an exploitable stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure.
1Tenable
1Nessus
Nov 21, 2024
May 18, 2018
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
In Nessus before 7.1.0, a XSS vulnerability exists due to improper input validation. A remote authenticated attacker could create and upload a .nessus file, which may be viewed by an administrator allowing for the execut...Show more
In Nessus before 7.1.0, a XSS vulnerability exists due to improper input validation. A remote authenticated attacker could create and upload a .nessus file, which may be viewed by an administrator allowing for the execution of arbitrary script code in a user's browser session. In other scenarios, XSS could also occur by altering variables from the Advanced Settings.Show less
1Misp Project
1Misp
Nov 21, 2024
May 18, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
app/webroot/js/misp.js in MISP 2.4.91 has a DOM based XSS with cortex type attributes.
1Ilias
1Ilias
Nov 21, 2024
May 18, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
error.php in ILIAS 5.2.x through 5.3.x before 5.3.4 allows XSS via the text of a PDO exception.
1Ilias
1Ilias
Nov 21, 2024
May 18, 2018
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Services/Form/classes/class.ilDateDurationInputGUI.php and Services/Form/classes/class.ilDateTimeInputGUI.php in ILIAS 5.1.x through 5.3.x before 5.3.4 allow XSS via an invalid date.