← Back
CWE-79

48,774 CVEs • Abstraction: Base • Likelihood of Exploit: High

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

JSON object

Loading...

CVEs (48,774)

CVE
VENDORS
PRODUCTS
UPDATED
PUBLISHED
CVSS
1Ozlabs
1Patchwork
Jun 17, 2026
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
A Cross Site Scripting (XSS) vulnerability exists in the template tag used to render message ids in Patchwork v1.1 through v2.1.x. This allows an attacker to insert JavaScript or HTML into the patch detail page via an em...Show more
A Cross Site Scripting (XSS) vulnerability exists in the template tag used to render message ids in Patchwork v1.1 through v2.1.x. This allows an attacker to insert JavaScript or HTML into the patch detail page via an email sent to a mailing list consumed by Patchwork. This affects the function msgid in templatetags/patch.py. Patchwork versions v2.1.4 and v2.0.4 will contain the fix.Show less
1Gitlab
1Gitlab
Nov 21, 2024
Jul 10, 2019
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
GitLab EE version 11.5 is vulnerable to a persistent XSS vulnerability in the Operations page. This is fixed in 11.5.1.
2Debian
Mediawiki
2Debian Linux
Mediawiki
Jun 17, 2026
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 an...Show more
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.Show less
1Gitlab
1Gitlab
Nov 21, 2024
Jul 10, 2019
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
GitLab CE/EE, versions 7.6 up to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, are vulnerable to an XSS vulnerability in the OAuth authorization page.
1Gitlab
1Gitlab
Nov 21, 2024
Jul 10, 2019
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
GitLab CE/EE, versions 10.3 up to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, are vulnerable to an XSS vulnerability in Markdown fields via Mermaid.
1Gitlab
1Gitlab
Nov 21, 2024
Jul 10, 2019
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
GitLab CE/EE, versions 11.3 before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, are vulnerable to an XSS vulnerability in Markdown fields via unrecognized HTML tags.
1Gitlab
1Gitlab
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in GitLab Community and Enterprise Edition 11.x before 11.3.11, 11.4.x before 11.4.8, and 11.5.x before 11.5.1. There is a persistent XSS vulnerability in the environment pages due to a lack of in...Show more
An issue was discovered in GitLab Community and Enterprise Edition 11.x before 11.3.11, 11.4.x before 11.4.8, and 11.5.x before 11.5.1. There is a persistent XSS vulnerability in the environment pages due to a lack of input validation and output encoding.Show less
1Paypal
1Adaptive Payments Sdk
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
paypal/adaptivepayments-sdk-php v3.9.2 is vulnerable to a reflected XSS in the SetPaymentOptions.php resulting code execution
1Teclib Edition
1News
Jun 17, 2026
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in the Teclib News plugin through 1.5.2 for GLPI. It allows a stored XSS attack via the $_POST['name'] parameter.
1Nagios
1Nagios Xi
Nov 21, 2024
Jul 10, 2019
N/A· v4
4.8 MEDIUM· v3
3.5 LOW· v2
Nagios XI before 5.5.4 has XSS in the auto login admin management page.
1Eventum Project
1Eventum
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in Eventum 3.5.0. /htdocs/list.php has XSS via the show_notification_list_issues or show_authorized_issues parameter.
1Eventum Project
1Eventum
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in Eventum 3.5.0. /htdocs/popup.php has XSS via the cat parameter.
1Eventum Project
1Eventum
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in Eventum 3.5.0. /htdocs/validate.php has XSS via the values parameter.
1Eventum Project
1Eventum
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in Eventum 3.5.0. htdocs/switch.php has XSS via the current_page parameter.
1Eventum Project
1Eventum
Nov 21, 2024
Jul 10, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
An issue was discovered in Eventum 3.5.0. htdocs/ajax/update.php has XSS via the field_name parameter.
1Yoast
1Yoast Seo
Jun 17, 2026
Jul 9, 2019
N/A· v4
9.8 CRITICAL· v3
7.5 HIGH· v2
The Yoast SEO plugin before 11.6-RC5 for WordPress does not properly restrict unfiltered HTML in term descriptions.
1Phpwind
1Phpwind
Jun 17, 2026
Jul 9, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
PHPWind 9.1.0 has XSS vulnerabilities in the c and m parameters of the index.php file.
1Keynto
1Team Password Manager
Jun 17, 2026
Jul 9, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
KEYNTO Team Password Manager 1.5.0 allows XSS because data saved from websites is mishandled in the online vault.
1Cyberpowersystems
1Powerpanel
Jun 17, 2026
Jul 9, 2019
N/A· v4
5.4 MEDIUM· v3
3.5 LOW· v2
A stored XSS vulnerability in the Agent/Center component of CyberPower PowerPanel Business Edition 3.4.0 allows a privileged attacker to embed malicious JavaScript in the SNMP trap receivers form. Upon visiting the /agen...Show more
A stored XSS vulnerability in the Agent/Center component of CyberPower PowerPanel Business Edition 3.4.0 allows a privileged attacker to embed malicious JavaScript in the SNMP trap receivers form. Upon visiting the /agent/action_recipient Event Action/Recipient page, the embedded code will be executed in the browser of the victim.Show less
1Apachefriends
1Xampp
Jun 17, 2026
Jul 9, 2019
N/A· v4
6.1 MEDIUM· v3
4.3 MEDIUM· v2
iart.php in XAMPP 1.7.0 has XSS, a related issue to CVE-2008-3569.