← Back
CWE-20

13,737 CVEs • Abstraction: Class • Likelihood of Exploit: High

Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

JSON object

Loading...

CVEs (13,737)

CVE
VENDORS
PRODUCTS
UPDATED
PUBLISHED
CVSS
1Sap
1S/4hana
Jun 17, 2026
Jul 12, 2022
N/A· v4
5.3 MEDIUM· v3
5.0 MEDIUM· v2
Due to missing input validation in the Manage Checkbooks component of SAP S/4HANA - version 101, 102, 103, 104, 105, 106, an attacker could insert or edit the value of an existing field in the database. This leads to an...Show more
Due to missing input validation in the Manage Checkbooks component of SAP S/4HANA - version 101, 102, 103, 104, 105, 106, an attacker could insert or edit the value of an existing field in the database. This leads to an impact on the integrity of the data.Show less
1Kubernetes
1Aws Iam Authenticator
Jun 17, 2026
Jul 12, 2022
N/A· v4
8.8 HIGH· v3
6.0 MEDIUM· v2
A security issue was discovered in aws-iam-authenticator where an allow-listed IAM identity may be able to modify their username and escalate privileges.
1Samsung
1Galaxy Store
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
7.2 HIGH· v2
Improper input validation vulnerability in BillingPackageInsraller in Galaxy Store prior to version 4.5.41.8 allows local attackers to launch activities as Galaxy Store privilege.
1Samsung
1Galaxy Store
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
7.2 HIGH· v2
Improper input validation vulnerability in ApexPackageInstaller in Galaxy Store prior to version 4.5.41.8 allows local attackers to launch activities as Galaxy Store privilege.
1Samsung
1Galaxy Store
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
7.2 HIGH· v2
Improper input validation vulnerability in AppsPackageInstaller in Galaxy Store prior to version 4.5.41.8 allows local attackers to launch activities as Galaxy Store privilege.
1Google
1Android
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
4.6 MEDIUM· v2
Improper validation vulnerability in ucmRetParcelable of KnoxSDK prior to SMR Jul-2022 Release 1 allows attackers to launch certain activities.
1Google
1Android
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
4.6 MEDIUM· v2
Improper validation vulnerability in CACertificateInfo prior to SMR Jul-2022 Release 1 allows attackers to launch certain activities.
1Google
1Android
Jun 17, 2026
Jul 12, 2022
N/A· v4
3.3 LOW· v3
2.1 LOW· v2
Improper input validation in Contacts Storage prior to SMR Jul-2022 Release 1 allows attacker to access arbitrary file.
1Google
1Android
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
7.2 HIGH· v2
Implicit Intent hijacking vulnerability in Finder prior to SMR Jul-2022 Release 1 allow allows attackers to launch certain activities with privilege of Finder.
1Google
1Android
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.8 HIGH· v3
7.2 HIGH· v2
Implicit Intent hijacking vulnerability in AppLinker prior to SMR Jul-2022 Release 1 allow allows attackers to launch certain activities with privilege of AppLinker.
1Siemens
1Simatic Easie Core Package
Jun 17, 2026
Jul 12, 2022
N/A· v4
7.5 HIGH· v3
5.0 MEDIUM· v2
A vulnerability has been identified in SIMATIC eaSie Core Package (All versions < V22.00). The affected systems do not properly validate input that is sent to the underlying message passing framework. This could allow an...Show more
A vulnerability has been identified in SIMATIC eaSie Core Package (All versions < V22.00). The affected systems do not properly validate input that is sent to the underlying message passing framework. This could allow an remote attacker to trigger a denial of service of the affected system.Show less
2Dell
Oracle
6Bsafe Crypto C Micro Edition
Bsafe Micro Edition SuiteDatabase+3 more
Jun 17, 2026
Jul 11, 2022
N/A· v4
9.8 CRITICAL· v3
7.5 HIGH· v2
Dell BSAFE Crypto-C Micro Edition, versions before 4.1.5, and Dell BSAFE Micro Edition Suite, versions before 4.5.2, contain an Improper Input Validation Vulnerability.
2Dell
Oracle
6Bsafe Crypto C Micro Edition
Bsafe Micro Edition SuiteDatabase+3 more
Jun 17, 2026
Jul 11, 2022
N/A· v4
9.8 CRITICAL· v3
7.5 HIGH· v2
Dell BSAFE Crypto-C Micro Edition, versions before 4.1.5, and Dell BSAFE Micro Edition Suite, versions before 4.6, contain an Improper Input Validation Vulnerability.
2Dell
Oracle
6Bsafe Crypto C Micro Edition
Bsafe Micro Edition SuiteDatabase+3 more
Jun 17, 2026
Jul 11, 2022
N/A· v4
9.8 CRITICAL· v3
7.5 HIGH· v2
Dell BSAFE Crypto-C Micro Edition, versions before 4.1.4, and Dell BSAFE Micro Edition Suite, versions before 4.4, contain an Improper Input Validation Vulnerability.
3Debian
EclipseNetapp
7Debian Linux
Element Plug In For Vcenter ServerHci Compute Node+4 more
Jun 17, 2026
Jul 7, 2022
N/A· v4
2.7 LOW· v3
4.0 MEDIUM· v2
In Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment of an http scheme URI, the Jetty HttpURI class improperly detects an invalid inpu...Show more
In Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment of an http scheme URI, the Jetty HttpURI class improperly detects an invalid input as a hostname. This can lead to failures in a Proxy scenario.Show less
1Hyperledger
1Fabric
Jun 17, 2026
Jul 7, 2022
N/A· v4
7.5 HIGH· v3
5.0 MEDIUM· v2
Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commi...Show more
Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.Show less
1Cybozu
1Garoon
Jun 17, 2026
Jul 4, 2022
N/A· v4
6.5 MEDIUM· v3
4.0 MEDIUM· v2
Improper input validation vulnerability in Space of Cybozu Garoon 4.0.0 to 5.5.1 allows a remote authenticated attacker to repeatedly display errors in certain functions and cause a denial-of-service (DoS).
1Cybozu
1Garoon
Jun 17, 2026
Jul 4, 2022
N/A· v4
4.3 MEDIUM· v3
4.0 MEDIUM· v2
Improper input validation vulnerability in Scheduler of Cybozu Garoon 4.0.0 to 5.5.1 allows a remote authenticated attacker to alter the data of Scheduler.
1Cybozu
1Garoon
Jun 17, 2026
Jul 4, 2022
N/A· v4
4.3 MEDIUM· v3
4.0 MEDIUM· v2
Improper input validation vulnerability in Link of Cybozu Garoon 4.0.0 to 5.5.1 allows a remote authenticated attacker to disable to add Categories.
1Cybozu
1Garoon
Jun 17, 2026
Jul 4, 2022
N/A· v4
4.3 MEDIUM· v3
4.0 MEDIUM· v2
Improper input validation vulnerability in Space of Cybozu Garoon 4.0.0 to 5.5.1 allows a remote authenticated attacker to alter the data of Space.