← Back

CVE-2026-10148

nvd nist
Published: Sep 12, 2026Modified: Sep 14, 2026Deferred

JSON object

Loading...
6.4
Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Exploitability: 3.1 / Impact: 2.7
Source: security@wordfence.com (Secondary)

Description

The Booking for Appointments and Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Elementor widgets in versions up to and including 2.4.9. This is due to insufficient input sanitization and output escaping on the 'load_manually' parameter in the render() methods of classes. This makes it possible for authenticated attackers, with Contributor-level access and above who can use Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.4.8.

References (13)

Timeline

No history available yet.