← Back

CVE-2021-37404

nvd nist
Published: Jun 13, 2022Modified: Jun 17, 2026

JSON object

Loading...
9.8
Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Exploitability: 3.9 / Impact: 5.9
Source: NVD

Description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected (4)

Products: Apache: Hadoop
1 product
Hadoop
Configuration A
4 vulnerable
Vulnerable SoftwareAffected Versions
Apache
2.9.0 ≤ version < 2.10.2
3.0.0 ≤ version ≤ 3.1.4
3.2.0 ≤ version < 3.2.3
3.3.0 ≤ version < 3.3.2

References (4)

Source: security@apache.org
Third Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
Mailing List
Source: af854a3a-2127-422b-91ae-364da2661108
Third Party Advisory

Timeline

No history available yet.